fehlerhafte Darstellung von Normalmaps in Cinema4D!?

Stellt Eure in Arbeit befindlichen oder fertigen 3D-Artworks hier aus, um sie diskutieren zu lassen.
Antworten
Benutzeravatar
JohnDoe
Member
Beiträge: 197
Registriert: 22. Feb 2007, 16:36
Wohnort: LE
Kontaktdaten:

fehlerhafte Darstellung von Normalmaps in Cinema4D!?

Beitrag von JohnDoe » 9. Okt 2008, 14:21

Hallo Leute,

bin für ein momentanes Projekt auf Detaildarstellung durch Normalmaps in Cinema4D angewiesen.
Was grundsätzl. kein Problem darstellt, nur macht mir ausgerechnet C4d einen Strich durch die Rechnung indem es Tangentspacenormalmaps, die ich für die Characters verwenden muss, unerklärlicherweise falsch bzw. fehlerhaft darstellt.

Ich testete die Maps erfolgreich in anderen Programmen u.a. Ogre3D, Blender sowie in 'Xnormal' in dem ich diese erstellen liess.
Nur C4d rendert mir diese Artefakte, die auf mich aus wie eine 'Mixtur' aus flatshaded Normals und den Normalen, die die Tangentspacenormalmap angibt, wirkt.
Objectspacemaps werden korrekt, ohne diese Fehler dargestellt.

Mir ist bewusst, dass es hier nicht allzuviele Cinema4Dbenutzer gibt,
aber ich habe mich mittlerweile im Netz Wundgesucht und nicht mal in den Foren der C4dcommunity und des Herstellers eine Spur gefunden, als ob es diese Funktion nicht gäbe oder niemand diese bräuchte... :?
Und dazu bekam man hier meisst rel. schnell und verlässlich Antwort. ;)

in den renders leider zu gut zu erkennen.
Bild

Bild

in den Totalen und der Animation, die hauptsächlich gerndert werden müssen, fällt es durch die Entfernung zu den Characters glücklicherweise nicht ins Gewicht. Jedoch sind auch Closeups geplant, für die ich mit diesem Problem schwarz sehe.

Bild

habe mit sogut wie allem, was damit zusammenhängen könnte frustriert versucht diese Darstellung zu verändern,erfolglos; :|

- auf einer völlig ebenen Fläche gibt es keine Artefakte, erst auf 'gerundeten' Meshes tritt das Problem auf
- der 'Phong'tag hat keine Auswirkung, ausgenommen der verschlimmerung des FX
- der UVmesh hinterlässt zwar Seams aber nicht an den Problemstellen
- Hypernurbs-Unterteilung hilft nicht, die 'problematisch-harten'Polys werden zwar unterteilt, aber 'hart' dargestellt
- Lowpolynormalen sind positiv, alle Polys sowie 'UVpolys' an den Problemstellen verbunden , die Map ist nicht invertiert
- das Ergebnis ändert sich nicht mit bestimmten Licht und Schattentypen,sowie deren Einstellungen, (die Probleme/Artefakte bereiten könnten)

Hat ein C4dnutzer vllcht einen Tip,Hinweis oder Idee?
oder musste selber schon mit diesem Problem kämpfen?

grüsse J.D
Through this fog they come along. Dark creatures singing a terrible song.
The rest of the bar laughed at him. Only I felt my hope grow dim.
They found him dead the very next day. "No more stories from him," I heard them say...
We blamed bad luck for his fate. Only I felt terror so great...

~ http://the-john-doe.deviantart.com ~

Benutzeravatar
cap
Senior Member
Beiträge: 458
Registriert: 24. Mär 2007, 22:03
Wohnort: Nürnberg
Kontaktdaten:

Beitrag von cap » 9. Okt 2008, 19:14

Dein Problem hat mich dazu angespornt, mich auch mal wieder mit den Normal Maps in Cinema zu beschäftigen. Nach vielen vergeblichen Versuchen eine richtig gut funktionierende normal map in zbrush zu erstellen und diese dann in Cinema einzufügen, hab ich mich damals wieder mit anderen Dingen beschäftigt.
Jetzt da du die Begriffe "Tangentspacenormals" und "Objectspacenormals" erwähnt hast, hab ich das gemacht, was ich schon damals hätte machen sollen: auf die interne cinema-hilfe zurückgreifen und die entsprechenden artikel nachlesen; statt der Try and Error Methode.
Daraufhin ist mir einiges klar geworden:
Das was ich wollte, waren normalmaps für gamecharakter; ich hab fälschlicherweise mit zbrush eine objectspacenormal gebacken und irgendwie hat das die ganzen fehler verursacht. Nach einem kurzen Test hat jetzt alles wunderbar geklappt.
Nachdem was ich aus deiner Schilderung entnehmen konnte, bist du ja wirklich vom Fach und wirst das bestimmt richtig gemacht haben. Ich wollts bloß mal erwähnen und mich auch bedanken, dass mich durch dein Problem der Ehrgeiz wieder gepackt hat. :)

Benutzeravatar
JohnDoe
Member
Beiträge: 197
Registriert: 22. Feb 2007, 16:36
Wohnort: LE
Kontaktdaten:

Beitrag von JohnDoe » 10. Okt 2008, 10:37

Danke für die Antworten.

Ja, muss für 'sich-selbst-verziehende' Objekte Tangentspace benutzen, da diese rel. zum Mesh berechnet werden und somit in jeder Characterbewegung und Stellung korrekt berechnet werden.
Nunjah, an der Erstellung oder der Map an sich kannes eigntlich nicht liegen.
(Seit einer der frühesten Versionen von 'Xnormal' schwör ich auf das Programm und benutzte dessen errechnete Normalmaps(egal ob TS oder OS) problemlos für die verschiedensten Zwecke, Hauptsächlich Echtzeitanwendungen.)

Habe in C4d aber bis jetzt nur Objktspcemaps gerendert. Habe schon mit dem Vertauschen der Normalmapkoordinaten rumgespielt - hat leider nur nicht zuviel Wirkung auf TSmaps und ändert an dem Darstellungsprob auch nichts :(

Danke trotzdem
Through this fog they come along. Dark creatures singing a terrible song.
The rest of the bar laughed at him. Only I felt my hope grow dim.
They found him dead the very next day. "No more stories from him," I heard them say...
We blamed bad luck for his fate. Only I felt terror so great...

~ http://the-john-doe.deviantart.com ~

Benutzeravatar
der_On
Senior Member
Beiträge: 313
Registriert: 29. Mai 2006, 01:32
Wohnort: Leipzig
Kontaktdaten:

Beitrag von der_On » 12. Okt 2008, 18:16

Ich arbeite derzeit an dem selben Projekt mit JohnDoe und wollte noch hinzufügen:

Die Probleme treten ja selbst dann auf, wenn man aus Cinema heraus eine Tangent-space Normal map backen lässt. Dann werden direkt in die Normalmap bereits diese Artefakte mit hineingebacken. Weiterhin funktionierte die gleiche Normalmap in Blender problemlos.

Benutzeravatar
Neox
Artguy
Beiträge: 1675
Registriert: 29. Mai 2006, 01:51
Wohnort: Berlin
Kontaktdaten:

Beitrag von Neox » 12. Okt 2008, 18:53

hm das is natürlich blöd wenn er in die normalmap die tangenten des Lowpolymodels mit reinhaut, gibts da keine Optionen das auszustellen bzw auch andere shader die das problem bei sauberen Normalmaps abfangen? In solchen Fällen ist es in Game Engines fast immer der Shader, der da scheisse baut
bonus vir semper tiro

Benutzeravatar
JohnDoe
Member
Beiträge: 197
Registriert: 22. Feb 2007, 16:36
Wohnort: LE
Kontaktdaten:

Beitrag von JohnDoe » 14. Okt 2008, 10:55

Hey Neox.

Wir sind für das Projekt auf Cinema4d und dessen Renderer angewiesen.
In einer der Gameengines ist die Darstellung Artefakt/Problemfrei.
Die Option an der Tangentendarstellung bzw. des shadings der Faces des Lowpolymodelles etwas zu verändern führt an sich nur zu flatshaded Faces die dann auch 'sauber' mit der TSnormalmap gemischt werden ...
Ansonsten gibt es nicht wirklich Einstellungsmöglichkeiten für die nutzung von Normalmaps; ist leider auch kaum dokumentiert -ausser, es gibt sie und man kann die koordinatenfarben vertauschen.

Habe inzwischen erfahren das dieses Problem schon seit der Möglichkeit Normalmaps zu nutzen besteht und auch in der kürzlich erschienen, neuesten Version 11 nicht behoben wurde. :(
Through this fog they come along. Dark creatures singing a terrible song.
The rest of the bar laughed at him. Only I felt my hope grow dim.
They found him dead the very next day. "No more stories from him," I heard them say...
We blamed bad luck for his fate. Only I felt terror so great...

~ http://the-john-doe.deviantart.com ~

Benutzeravatar
Neox
Artguy
Beiträge: 1675
Registriert: 29. Mai 2006, 01:51
Wohnort: Berlin
Kontaktdaten:

Beitrag von Neox » 14. Okt 2008, 11:22

hm und ich nehm mal an die object space normalmap nimmt die deformation des meshes nich sauber mit?
bonus vir semper tiro

Benutzeravatar
JohnDoe
Member
Beiträge: 197
Registriert: 22. Feb 2007, 16:36
Wohnort: LE
Kontaktdaten:

Beitrag von JohnDoe » 14. Okt 2008, 15:03

jepp, right ye are :|

Edit; (wird dann (wie eigntlich auch erwartet) beleuchtet ols ob die Meshteile noch in der Ausgangsposition wären)
Bin im mom soweit für die Close-ups die OSnormalmaps zu verwenden, da die Mimik-morphtargets den Schädelmesh nicht zu sehr verziehen und es dabei nicht zu sehr auffällt .(ausser uns)
Through this fog they come along. Dark creatures singing a terrible song.
The rest of the bar laughed at him. Only I felt my hope grow dim.
They found him dead the very next day. "No more stories from him," I heard them say...
We blamed bad luck for his fate. Only I felt terror so great...

~ http://the-john-doe.deviantart.com ~

Benutzeravatar
cap
Senior Member
Beiträge: 458
Registriert: 24. Mär 2007, 22:03
Wohnort: Nürnberg
Kontaktdaten:

Beitrag von cap » 14. Okt 2008, 20:36

Ich würd mich gern nochmal in das Thema einklinken; obwohl ich befürchte, dass ich euch beiden nicht wirklich weiterhelfen kann. Ich hab versucht bei meinem funktionierenden Tangent-Space-Normalmap-Testobjekt auf ein ähnlich fehlerhaftes Ergebnis zu kommen, um herauszufinden an was es liegen könnte.
Dabei hab ich die Standartwerte unter den Normalmap Eigenschaften verändert und siehe da: die gleichen hässlichen Ecken wie bei eurem Model.
Mein Tipp: Geht sicher, dass bei folgenden Parametern der entsprechende Standartwert eingetragen ist:

Unter Basis Eigenschaften:
Blur-Offset: 0% !

Unter den Shader Eigenschaften:
Belichtung: 0 !
Schwarzpunkt: 0 !
Weißpunkt: 1 !

Außerdem hab ich festgestellt, dass sich alle Schattentypen (incl. ambient occlusion) verschieden auf das mesh auswirken.
Treten die Kanten auch auf wenn sich keine Lichtquelle in der Szene befindet und AO deaktiviert ist?

Benutzeravatar
JohnDoe
Member
Beiträge: 197
Registriert: 22. Feb 2007, 16:36
Wohnort: LE
Kontaktdaten:

Beitrag von JohnDoe » 19. Okt 2008, 17:45

Hey, Cap

Danke dass du dir Gedanken um die Problemlösung machst.

Ich kannes zwar gerade nicht überprüfen, doch bin ich mir zu 96% sicher dass wir die TSnormalmap nicht nochmal von C4d durch die von Dir genannten Einstellungen verändern liessen, wüsste auch nicht warum ...
(ausser den Versuchen, die Koordinaten zu spiegeln usw.)

Gibt es denn bei deinen Versuchen, die Standartwerte einfach zu belassen, keine dieser Artefakte :?

Was die Licht/Schatten und best. FX Ergebnisse angeht, ist, wie Eingangs erwähnt, schon alles
(was mir einfiel) durchgetestet worden.
Die geposteten Shots sind 'ohne alles' --> 1Punktlichtqelle ohne Schatten, ohne AO, Sss, usw.

Und was deinen Tip angeht, hehe ^^ (entschuldige)
aber einerseits sollten in der endgültigen Fassung schon Lichter mitgerendert werden und würden wir keine Lichter brauchen, müssten wir uns auch keine Sorge um das shading der Normalmaps machen müssen, da es kein Licht gibt was auf der Oberfläche bestimmte Details shaden soll
-wäre ja alles derselbe Helligkeitswert.

Falls du andere Ergebnisse erzielen solltest, zeig her ...

Grüsse, der üble JD
Through this fog they come along. Dark creatures singing a terrible song.
The rest of the bar laughed at him. Only I felt my hope grow dim.
They found him dead the very next day. "No more stories from him," I heard them say...
We blamed bad luck for his fate. Only I felt terror so great...

~ http://the-john-doe.deviantart.com ~

Benutzeravatar
cap
Senior Member
Beiträge: 458
Registriert: 24. Mär 2007, 22:03
Wohnort: Nürnberg
Kontaktdaten:

Beitrag von cap » 2. Nov 2008, 18:55

Hey übler JD!
Lang ist's her; hatte irgendwie nich so viel Zeit in letzter Zeit :D
Natürlich hast du vollkommen recht mit den Lichtern. Normalmapping ist für mich eben ein ziemlich unbekanntes Gebiet. Also hab ich versucht nach irgendeinem Weg zu suchen um das Problem zu lösen, da es bei mir ja super geklappt hat.
Hier mal meine Ergebnisse:
(man beachte das wunderschöne UV-Layout :D)

Bild
Bild
Bild
Bild
Bild
Bild

Benutzeravatar
JohnDoe
Member
Beiträge: 197
Registriert: 22. Feb 2007, 16:36
Wohnort: LE
Kontaktdaten:

Beitrag von JohnDoe » 3. Nov 2008, 17:24

hey there.

Danke für diese ausführliche optische doku :)
Hätte das ganze gern noch ohne Nurbsunterteilung mit der Normalmap gesehn...
Through this fog they come along. Dark creatures singing a terrible song.
The rest of the bar laughed at him. Only I felt my hope grow dim.
They found him dead the very next day. "No more stories from him," I heard them say...
We blamed bad luck for his fate. Only I felt terror so great...

~ http://the-john-doe.deviantart.com ~

Benutzeravatar
cap
Senior Member
Beiträge: 458
Registriert: 24. Mär 2007, 22:03
Wohnort: Nürnberg
Kontaktdaten:

Beitrag von cap » 3. Nov 2008, 21:11

hmm...ich hab das lowpolymesh so aus zbrush übernommen und nicht nachträglich in ein Hypernurbsobjekt gesteckt. Wüsste jetzt spontan nicht wie ich da noch was ändern könnte, da meine UV map auch auf diesem mesh basiert. :?

Benutzeravatar
JohnDoe
Member
Beiträge: 197
Registriert: 22. Feb 2007, 16:36
Wohnort: LE
Kontaktdaten:

Beitrag von JohnDoe » 3. Nov 2008, 21:32

Achso ... mist
(Bin davon ausgegangen dass du das Mesh in C4d erstellt hattest)
Through this fog they come along. Dark creatures singing a terrible song.
The rest of the bar laughed at him. Only I felt my hope grow dim.
They found him dead the very next day. "No more stories from him," I heard them say...
We blamed bad luck for his fate. Only I felt terror so great...

~ http://the-john-doe.deviantart.com ~

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder